Please note, the information in this article applies to a previous version of our app. The content is being updated to reflect the new version changes.

Our app works on:

Most major browsers

iOS 9.0 or later

Android 5.0 or later (including Android tablets)

For security reasons, the app won’t work if your device is rooted, jailbroken or uses custom ROMs

Did this answer your question?